ようこそ!浜村拓夫の世界へ

    ブログ内検索

    最近の記事

    ブックマーク数の多い記事

    Blog Translation

    Powered By FC2ブログ

    Powered By FC2ブログ
    ブログやるならFC2ブログ


    FC2ブログ LOGIN

    with Ajax Amazon

    Ruby on Rails 学習日記 その1 Rubyのバージョン

    このエントリーを含むはてなブックマーク はてなブックマーク - Ruby on Rails 学習日記 その1 Rubyのバージョン あとで読む
    思い立ったが吉日。

    そのうちやろうと思って、ずっと先延ばしにしていたRuby on Railsを、今日から勉強してみようと思います。

    ruby logo

    準備は、何もしていません。
    本も買っていません。
    とりあえずネットで調べることから始めてみます。
    (備忘録として勉強の軌跡をメモ)

    ●Rubyとは?
    Ruby - Wikipedia

    Ruby(ルビー)は、まつもとゆきひろ(通称Matz)により開発されたオブジェクト指向スクリプト言語であり、従来Perlなどのスクリプト言語が用いられてきた領域でのオブジェクト指向プログラミングを実現する。



    公式サイト
    オブジェクト指向スクリプト言語 Ruby

    日本Rubyの会 公式Wiki
    (旧) http://jp.rubyist.net/
    (新) https://github.com/ruby-no-kai/official/wiki

    ●Rubyのバージョン
    Rubyは、2012年5月29日現在、バージョンが1.8.7と1.9.3の二つがありました。
    1.8系と1.9系、これから使うなら、1.9系がオススメとのことです。

    1.8.7の今後につきまして (2011-10-07)

    Rubyのコア開発者は、今現在はより新しいバージョン、1.9に注力しており、 近々最新版である1.9.3のリリース準備を進めているところです。
    私たちも以前から1.9を使っており、率直なところ、今さら1.9以前のバージョンに戻るのは ちょっと無理というほどです。
    新しく追加した数々の機能、迅速な実行、RubyGemsの統合、 さらにはRailsも1.9に移行しています。
    控えめに言っても、1.9は大変優れていると言わざるをえません。
    みなさまにおかれましても、1.9をお使いいただくことを心よりお勧めする次第です。



    1.9を使ってくれと。

    今後の予定
    ・2012年6月まで、通常のメンテナンスが続きます。
    ・それ以降、バグフィックスリリースは終了いたします。2013年6月まではセキュリティフィックスは続けますので、それまでは1.8.7をお使いいただけます。
    ・2013年6月より先は、1.8.7はあらゆるサポート対象外になります。



    1.8は、そろそろサポート終了するよと。

    …了解です。
    Ruby1.9系を使ってみることにします。




    クックパッドでは、Ruby1.8を使ってんのか~。

    いまさら、RubyKaigi2011を振り返る - プログラマ 福重 伸太朗 ~基本へ帰ろう~

    Ruby を利用した大規模ウェブサービスの開発・運用では、クックパッドさんがRuby を用いてどのように開発・運用されているのかを話されていました。

    ・Ruby 1.8.7
    ・Rails 2.3



    まあ、いいや。

    たのしいRuby 第3版
    高橋 征義
    ソフトバンククリエイティブ
    2010-03-31
    2730円
    ★★★★★

    関連記事

    コメント

    コメントの投稿


    管理者にだけ表示を許可する

    トラックバック

    トラックバックURL:
    http://hamamuratakuo.blog61.fc2.com/tb.php/802-6eccaf83

    FC2Ad